1117 Eddington Number (25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/acm_zh/article/details/87911195

1117 Eddington Number (25 分)

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6
#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
int cmp(int a,int b){
	return a > b;
}
int main(){
	int n;
	cin >> n;
	int cnt = 0;
	vector<int> v(100005);
	for(int i = 0;i < n;i++){
		cin >> v[i];
	} 
	sort(v.begin(),v.end(),cmp);
	while(cnt < n&&v[cnt] > cnt+1){
		cnt++;
	}
	cout << cnt << endl;
}

猜你喜欢

转载自blog.csdn.net/acm_zh/article/details/87911195