PAT(A) 1117. Eddington Number(25)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/huqiao1206/article/details/79514473

原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1117

1117. Eddington Number(25)


“British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an “Eddington number”, E – that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington’s own E was 87.

Now given everyday’s distances that one rides for N days, you are supposed to find the corresponding E (<=N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N(<=105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:
10
6 7 6 9 3 10 8 2 7 8
Sample Output:
6

题目大意

找出存在的数E,使得存在E天Eddington的里程达到了E miles,使E尽可能得大。

解题报告

先排序,再把E从N到0进行检测,找到即停。

代码

/*
* Problem: 1117. Eddington Number(25)
* Author: HQ
* Time: 2018-03-11
* State: Done
* Memo:
*/
#include "iostream"
#include "vector"
#include "algorithm"
using namespace std;

vector<int> dis;
int N;

int main() {
    cin >> N;
    int x;
    for (int i = 0; i < N; i++) {
        cin >> x;
        dis.push_back(x);
    }
    sort(dis.begin(), dis.end());
    int i;
    for (i = N; i > 0; i--) {
        if (dis[N - i] > i) {
            break;
        }
    }
    cout << i << endl;
    system("pause");
}

猜你喜欢

转载自blog.csdn.net/huqiao1206/article/details/79514473