PAT A1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2… NK aNK
where K is the number of nonzero terms in the polynomial, N​i and aNi(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

题意:

输出两个多项式相加的结果,格式为(非零项指数降序输出):
非零项个数 非零项指数 非零项系数 …

思路:

(1)开3个浮点型数组a,b,c,存放输入的2个多项式与求和后的多项式,下标为指数,对应的值为系数;
(2)a,b逐项相加求得c,输出c的非零项个数,降序输出c的指数和系数.

代码:

#include <cstdio>
#include <iostream>
#include <iomanip>
using namespace std;
const int maxn=1010;
int main(){
	int k1,k2,n1,n2,count=0;
	double a1,a2,a[maxn]={},b[maxn]={},c[maxn]={};
	cin>>k1;
	for(int i=0;i<k1;i++){
		cin>>n1>>a1;
		a[n1]=a1;
	}
	cin>>k2;
	for(int i=0;i<k2;i++){
		cin>>n2>>a2;
		b[n2]=a2;
	}
	for(int i=0;i<maxn;i++){
		c[i]=a[i]+b[i];
		if(c[i]!=0){
			count++;
		}
	}
	cout<<count;
	cout<<setiosflags(ios::fixed)<<setprecision(1);//保留1位小数点输出
	for(int i=maxn-1;i>=0;i--){
		if(c[i]!=0)
		cout<<' '<<i<<' '<<c[i];
	}
	return 0;
}

词汇:

polynomial 多项式
coefficient 系数
exponent 指数

发布了26 篇原创文章 · 获赞 0 · 访问量 497

猜你喜欢

转载自blog.csdn.net/PanYiAn9/article/details/101550163