HDU1711 Number Sequence(KMP模板题)

Number Sequence
Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 40053    Accepted Submission(s): 16510


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 

Sample Output
6
-1

#include<iostream>
#include<string.h>
using namespace std;
int tt,pp;
int t[1000011],p[11111],next1[11111];
void getnext()
{
    int i=0,j=-1;
    next1[0]=-1;
    while(i<pp-1)
    {
        if(j==-1||p[i]==p[j])
            next1[++i]=++j;
        else
            j=next1[j];
    }
    return;
}
int kmp()
{
    int i=0,j=0;
    while(i<tt)
    {
        if(j==-1||t[i]==p[j])
            i++,j++;
        else
            j=next1[j];
        if(j==pp)
            return i-j+1;
    }
    return -1;
}
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d%d",&tt,&pp);
        for(int i=0;i<tt;i++)
            scanf("%d",&t[i]);
        for(int i=0;i<pp;i++)
            scanf("%d",&p[i]);
        getnext();
        printf("%d\n",kmp());
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42060896/article/details/81748738