并查集 How Many Tables 最小生成树

 

Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

Sample Input

 

2 5 3 1 2 2 3 4 5 5 1 2 5

 

Sample Output

 

2 4

#include<cstdio>
int pre[1010];
int find(int x) {
    int r=x;
    while(r!=pre[r]) {
        r=pre[r];
    }
    return r;
}
int main() {
    int t;
    scanf("%d",&t);
    while(t--) {
        int n ,m;
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++) { //初始化
            pre[i]=i;
        }
        for(int i=0; i<m; i++) {
            int x,y;
            scanf("%d%d",&x,&y);
            int fx=find(x);
            int fy=find(y);
            if(fx!=fy) {
                pre[fx]=fy;
            }
        }
        int cnt=0;
        for(int i=1; i<=n; i++) { //求树的个数
            if(pre[i]==i) {
                cnt++;
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40835329/article/details/81631202