并查集--How Many Tables

How Many Tables

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers. 

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. 

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

测试样例分析:

#include<stdio.h>
#define MAX 1000
int n,m;//n个客人,m对关系 
int sum;//总共需要几张桌子
int fa[MAX];

int find(int x){//查询x的大队长 
	if(fa[x]==x) return x;//若x的小队长为自己,则他就是大队长 
	else return fa[x]=find(fa[x]);//否则让x的小队长去询问他的小队长 
}
void merge(int x,int y){
	int fx = find(x); //找到x的大队长 
	int fy = find(y); //找到y的大队长 
	if(fx!=fy){
		fa[fy] = fx;//若不是同一个分队的,则fy并入fx队伍中 
		sum--; //合并成功,代表他们可以共用一张桌子 
		return ;
	}
	else return ;
}
int main(){
	int t;//t组测试样例
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&n,&m);//n个客人,m对关系 
	
		//初始化,每个人与其他人都没有关系
		sum = n;
		for(int i = 1;i<=n;i++){
			fa[i] = i;
		} 
		
		int x,y; //x与y是一对朋友
		for(int i = 1;i<=m;i++){
			scanf("%d%d",&x,&y);
			merge(x,y);
		}
		printf("%d\n",sum);	
		 
	} 
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_40626497/article/details/81153896