【并查集】How Many Tables

描述

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

输入

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

输出

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

样例输入

2
5 3
1 2
2 3
4 5

5 1
2 5

样例输出

2
4

题目来源

HDOJ

分析:
并查集,一伙人坐一张桌子,统计一共有多少张桌子。

代码:

#include<bits/stdc++.h>
using namespace std;
int f[1010],num[1010];
int findit(int x)
{
    return x==f[x]?x:f[x]=findit(f[x]);
}
int Union(int x,int y)
{
    if (x!=y) f[x]=y;
}
int main()
{
    int T,n,m;
    cin>>T;
    while(T--)
    {
        memset(num,0,sizeof(num));
        int ans=0;
        cin>>n>>m;
        for (int i=1;i<=n;i++)
            f[i]=i;
        for (int i=1;i<=m;i++)
        {
            int A,B;
            cin>>A>>B;
            Union(findit(A),findit(B));
        }
        for (int i=1;i<=n;i++)
        {
            int w=findit(f[i]);
            if(num[w]==0) ans++;
            num[w]++;
        }
        cout<<ans<<endl;
    }
    return 0;
}

发布了122 篇原创文章 · 获赞 0 · 访问量 4666

猜你喜欢

转载自blog.csdn.net/Skynamer/article/details/104149440