How Many Tables//并查集

题目:

 

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41763    Accepted Submission(s): 20915

Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 
Sample Input
2
5 3
1 2
2 3
4 5
 
5 1
2 5
 
Sample Output
2
4
 
思路:
 
代码:
//按秩合并的并查集
#include <iostream>

int Find(int a[], int x)//找根
{
    while(x != a[x])
    {
        x = a[x];
    }
    return x;
}

bool IsConnected(int a[], int x, int y)//判断是否已连接
{
    return Find(a,x) == Find(a,y);
}

void Union(int a[], int b[], int x, int y)//合并两个树
{
    int c = Find(a,x);
    int d = Find(a,y);
    if(b[c] < b[d])//小的树连到大的树上
        a[c] = d;
    else
    {
        a[d] = c;
        if(b[c] == b[d])//若两个树高度相等,则合并后高度+1
            b[c]++;
    }
}

int main()
{
    using namespace std;
    int T;
    cin >> T;
    while(T--)
    {
        int N, M;
        int x, y; 
        cin >> N >> M;
        int num = N;
        int * a = new int[N+1];
        int * b = new int[N+1];//记录树的高度
        for(int i = 0; i < N+1; i++)
        {
            a[i] = i;
            b[i] = 1;
        }
        while(M--)
        {
            cin >> x >> y;
            if(IsConnected(a,x,y))
                continue;
            Union(a,b,x,y);
            num--;
        }
        printf("%d\n", num);
    }
}

猜你喜欢

转载自www.cnblogs.com/w-j-c/p/9218929.html