查并集(How Many Tables)

版权声明:本文为博主原创文章,转载请注明。 https://blog.csdn.net/qq_41181881/article/details/80425792

在初高中数学中我们都学过集合,也就知道集合的交集和并集。所以思路应该很明确,但是用代码表示要注意一下几个坑:

1)两个集合中可能有重复的元素,一定要查重;

2)两个集合合并,一定要将两个集合的所有元素都归到一个集合内;

 用一个经典的查并集算法题来解释一下

How Many Tables(并查集)

Link:https://cn.vjudge.net/contest/175491#problem/D

题目:

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

扫描二维码关注公众号,回复: 3952193 查看本文章

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input


5 3 
1 2 
2 3 
4 5

5 1 
2 5

Sample Output


4

思路:每个人是一个数组,两个数组内存的数如果相同,代表认识并成为一桌;(每个数组内刚开始都是自身编号)

给你们一组特殊测试数据:

输入:

1

5 4

1 2

1 3

4 3

3 4

输出:

2

代码内部讲解:

#include<iostream>
#include<cstdio>
int s[1005];
int n,m,i;
void chongzhi()//将每个人数组内的数重置一下  刚开始都是自身编号
{
    for(i=1;i<=n;i++)
    {
        s[i]=i;
    }
}
int bing(int x)//其实这个函数可以省略 只是为了更加清晰
{
    if(x==s[x])//如果数组内的数跟自身相同 就返回自身的数
    {
        return x;
    }
    return bing(s[x]);//如果不同 返回数组内存的数
}
int he(int x,int y)
{
    int t1=bing(x);
    int t2=bing(y);
    int t;
    if(t1!=t2)//如果两个数组的数不相同 将他们合并集合
    {
        t=s[t2];
        s[t2]=s[t1];
        for(i=1;i<=n;i++)//这个循环就是为了将 两个集合的所有元素合并 不仅仅是两个元素合并
        {
            if(s[i]==t)
            {
                s[i]=s[t1];
            }
        }
    }

}
int main()
{
    int t,j,k,l;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&m);//n个人 m个数据
        chongzhi();//调用上面的函数 将每个人数组内的数重置一下  刚开始都是自身编号
        int a,b;
        while(m--)
        {
            scanf("%d %d",&a,&b);
            s[a]=bing(a);
            s[b]=bing(b);
            he(s[a],s[b]);//合并集合
        }
        for(j=1;j<=n;j++)//排序
        {
            for(k=1;k<=n-j;k++)
            {
                if(s[k]>s[k+1])
                {
                    l=s[k];
                    s[k]=s[k+1];
                    s[k+1]=l;
                }
            }
        }
        l=1;
        for(j=1;j<n;j++)//查重
        {
            if(s[j]!=s[j+1])
                l++;
        }
        printf("%d\n",l);//输出剩余
    }
}







猜你喜欢

转载自blog.csdn.net/qq_41181881/article/details/80425792