How Many Tables-并查集

原题链接:https://vjudge.net/problem/19354/origin

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
Sample Output
2
4

题解:套并查集模版,最后遍历一下se[],看看有几个是指向自己的,有几个就要几个桌子

#include <bits/stdc++.h>
const int N=1005;
const int M=1005;
using namespace std;
int se[N];
int rk[N];
int fd(int a){
    int x=a;
    while(se[x]!=x){
        x=se[x];
        for(int i=a,j;i!=x;i=j){
            j=se[i];
            se[i]=x;
        }
    }
    return x;
}
void join(int a,int b){
    int fa=fd(a);
    int fb=fd(b);
    se[fb]=fa;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++) se[i]=i,rk[i]=1;
        while(m--){
            int a,b;
            scanf("%d%d",&a,&b);
            join(a,b);
        }
        int ans=0;
        for(int i=1;i<=n;i++) if(se[i]==i) ans++;
        printf("%d\n",ans);

    }
    //cout << "Hello world!" << endl;
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/-yjun/p/10350794.html