威佐夫博弈(poj1067)

取石子游戏

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 45072   Accepted: 15376

Description

有两堆石子,数量任意,可以不同。游戏开始由两个人轮流取石子。游戏规定,每次有两种不同的取法,一是可以在任意的一堆中取走任意多的石子;二是可以在两堆中同时取走相同数量的石子。最后把石子全部取完者为胜者。现在给出初始的两堆石子的数目,如果轮到你先取,假设双方都采取最好的策略,问最后你是胜者还是败者。

Input

输入包含若干行,表示若干种石子的初始情况,其中每一行包含两个非负整数a和b,表示两堆石子的数目,a和b都不大于1,000,000,000。

Output

输出对应也有若干行,每行包含一个数字1或0,如果最后你是胜者,则为1,反之,则为0。

Sample Input

2 1
8 4
4 7

Sample Output

0
1
0
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std ;
typedef long long LL ;
int main()
{
	LL a,b ;
	while(scanf("%lld%lld",&a,&b)!=EOF)
	{
		if(a>b)
		{
			swap(a,b);
		}
		LL d = b-a ;
		LL t = (LL)(d*(sqrt(5.0)+1)/2);
		if(t==a)
		{
			cout<<"0"<<endl;
		}
		else
		{
			cout<<"1"<<endl;
		}

	}





	return 0 ;
}

猜你喜欢

转载自blog.csdn.net/qq_41661809/article/details/81454135