hdoj 2147 kiki's game

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/10000 K (Java/Others)
Total Submission(s): 12431    Accepted Submission(s): 7556


Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 

Sample Input
 
  
5 3 5 4 6 6 0 0
 

Sample Output
 
  
What a pity! Wonderful! Wonderful!
 

Author
月野兔
 

Source
题意就是从右上角走到左下角,假设左下角坐标是(1,1),右上角坐标则为(m,n),只能走左,下,左下三个方向,然后  倒过来想,从(1,1)能一步到达的地方一定是含偶数的,所以只要谁先走到偶数谁就输了

#include<stdio.h>
int main(){
	int n,m;
	while(scanf("%d %d",&n,&m)!=EOF&&n&&m){
		if(n%2&&m%2)
		printf("What a pity!\n");
		else
		printf("Wonderful!\n");
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/dear_jia/article/details/80203279