HDU 2147 - kiki's game(博弈)

版权声明:欢迎转载 https://blog.csdn.net/l18339702017/article/details/82156623

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/10000 K (Java/Others)
Total Submission(s): 13298    Accepted Submission(s): 8127


 

Problem Description

Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?

 

Input

Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.
 

 

Output

If kiki wins the game printf "Wonderful!", else "What a pity!".

 

Sample Input

 

5 3

5 4

6 6

0 0

 

Sample Output

 

What a pity!

Wonderful!

Wonderful!

遇事不决先打表:

(1,1)        (1,2)        (1,3)        (1,4)
  败                   胜                  败                   胜
(2,1)        (2,2)        (2,3)        (2,4)
   胜                   胜                    胜                  胜
(3,1)        (3,2)        (3,3)        (3,4)
    败                     胜                    败                胜    

看出规律,横坐标或者纵坐标中有偶数的话,先手胜。

#pragma GCC optimize(2)
#include<bits/stdc++.h>
using namespace std;
#define clr(a) memset(a,0,sizeof(a))
#define rep(i,x,y) for(int i = x; i < y; i++)
#define Rep(i,x,y) for(int i = x; i <= y; i++)
#define per(i,x,y) for(int i = x; i >= y; i--)
#define line cout << "------------" << endl

typedef long long ll;
const int maxn = 1e5 + 10;
const int MAXN = 1e6 + 10;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;
const int N = 1010;

int main(){
	int n, m;
	while(scanf("%d%d", &n, &m) != EOF && (n||m)){
		if(n%2 == 0 || m%2 ==0) puts("Wonderful!");
		else puts("What a pity!");
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/l18339702017/article/details/82156623