HDOJ 2053 Switch Game

Problem Description

There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).

Input

Each test case contains only a number n ( 0< n<= 10^5) in a line.

Output

Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).

Sample Input

1
5

Sample Output

1
0

思路解析1:

这个题乍一看贼唬人,好多灯泡怎么破,其实仔细思考就会发现,灯泡都是假的,根本没卵用,最后求第n个灯的情况,就只跟n有关。
当遇到n的约数的时候灯会改变情况,所以只用求n有几个约数,然后判断奇偶性,奇数灯亮,偶数灯灭,就这么简单。

代码:

#include<iostream>
using namespace std;
int main()
{
    int n;
    while(cin>>n)
    {
        int a=0;
        for(int i=1;i<=n/2;i++)
        {
            if(n%i==0)
                a++;
        }
        a++;
        a=a%2;
        cout<<a<<endl;
    }
}

思路解析2:

一个数的约数总是成对出现的,当这个数的平方根为整数,既这个数存在一个约数的平方等于他本身时,这个数的约数为奇数。所以可以用验证平方根来做。

#include<iostream>
#include<math.h>
using namespace std;
int main()
{
    int a,b;
    while(cin>>a){
        b=sqrt(a);
        if(b*b==a)
            cout<<1<<endl;
        else cout<<0<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wanttifa/article/details/81325084