HDU 2147 kiki's game(博弈,PN图)

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/10000 K (Java/Others)
Total Submission(s): 12863    Accepted Submission(s): 7829


 

Problem Description

Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?

Input

Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.
 

Output

If kiki wins the game printf "Wonderful!", else "What a pity!".

Sample Input

 

5 3 5 4 6 6 0 0

Sample Output

 

What a pity! Wonderful! Wonderful!

一道bash的题,画出PN图就可以很清楚的看出n或m为偶数时,能win

首先左下的那个点一定是P,然后推出它上,右上,右的点是N,依此推出一张小表,就可以很轻松的得出结论

PN图PN图(随手画的,有点丑)
#include<bits/stdc++.h>
using namespace std;

int n,m;
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF&&n&&m)
    {
        if(n*m%2==0)
            printf("Wonderful!\n");
        else
            printf("What a pity!\n");
    }
}

猜你喜欢

转载自blog.csdn.net/qq_39239844/article/details/81093382