HDU2147 kiki's game

kiki’s game
Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can’t make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
Input
Input contains multiple test cases. Each line contains two integer n, m ( 0 < n, m<=2000 )The input is terminated when n=0 and m=0.
Output
If kiki wins the game printf “Wonderful!”, else “What a pity!”.
Sample Input
5 3
5 4
6 6
0 0
Sample Output
What a pity!
Wonderful!
Wonderful

分析:
以5*4为例, 用P代表必败, N代表必胜, 则最左下角为P, 能一步走到必败的为必胜, 只能走到必胜的为必败, 画表:

  1. PNPN
  2. NNNN
  3. PNPN
  4. NNNN
  5. PNPN
    由表可知, m或n可被2整除时先走的人必胜
#include<cstdio>

using namespace std;

int main()
{
    int n, m;
    scanf("%d %d", &n, &m);
    while(n)
    {
        if(n%2==0 || m%2==0)
            printf("Wonderful!\n");
        else
            printf("What a pity!\n");
        scanf("%d %d", &n, &m);
    }
    return 0;
}

分析参考博客NOIAu 浅谈巴什博弈

猜你喜欢

转载自blog.csdn.net/liudazhuang98/article/details/79919479