FZU OJ 2147 A-B Game (数学水题)

Problem 2147 A-B Game

Accept: 827    Submit: 1940
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Fat brother and Maze are playing a kind of special (hentai) game by two integers A and B. First Fat brother write an integer A on a white paper and then Maze start to change this integer. Every time Maze can select an integer x between 1 and A-1 then change A into A-(A%x). The game ends when this integer is less than or equals to B. Here is the problem, at least how many times Maze needs to perform to end this special (hentai) game.

 Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers A and B described above.

1 <= T <=100, 2 <= B < A < 100861008610086

 Output

For each case, output the case number first, and then output an integer describes the number of times Maze needs to perform. See the sample input and output for more details.

 Sample Input

25 310086 110

 Sample Output

Case 1: 1Case 2: 7

题意:

给出两个长整型的数a, b。有一种将a变化的操作为:a=a-(a%x),   其中   1<=x<=a-1;

问最少有多少次操作能使得a<=b。

思路:每次最多减去A/2;
#include <iostream>
#include <cstdio>
#include <cstring>
typedef long long ll;
using namespace std;
int main()
{
    int t,count,k=1;
    ll A,B;
    cin>> t;
    while(t--)
    {
        count=0;
        cin>>A>>B;
        while(A>B)
        {
            A=A/2;
            count++;
        }
        printf("Case %d: %d\n",k++,count);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/u014253173/article/details/45938335