HDU 2147 kiki's game(博弈找规律)

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/10000 K (Java/Others)
Total Submission(s): 12564    Accepted Submission(s): 7633


Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 
Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 
Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 
Sample Input
5 3 5 4 6 6 0 0
 
Sample Output
What a pity! Wonderful! Wonderful!
 
// 没找到规律  参考 https://blog.csdn.net/IAccepted/article/details/24738455
题意:一个n*m的表格,起始位置为右上角,目标位置为左下角,甲先开始走,走的规则是可以向左,向下或者向左下(对顶的)走一格。谁先走到目标位置谁就胜利。在甲乙都采用最佳策略的时候,先走者能否获胜。也是一个巴什博弈的题目。首先画出PN图,

如图就能很容易的看出,只要m或者n有一个是偶数先手就能必胜。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>

using namespace std;

int main(){

    int n,m;
    while(scanf("%d %d",&n,&m)!=EOF){
        if(n==0 && m==0)break;
        if(n%2==0 || m%2==0){
            printf("Wonderful!\n");
        }else{
            printf("What a pity!\n");
        }
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/yi-ye-zhi-qiu/p/9086107.html