kiki's game

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/10000 K (Java/Others)
Total Submission(s): 12922    Accepted Submission(s): 7873


 

Problem Description

Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?

 

Input

Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.
 

 

Output

If kiki wins the game printf "Wonderful!", else "What a pity!".

 

Sample Input

 

5 3 5 4 6 6 0 0

 

Sample Output

 

What a pity! Wonderful! Wonderful!

 

Author

月野兔

 

Source

HDU 2007-11 Programming Contest

AC代码

#include <cstdio>
#include <iostream>
using namespace std;
long long a,b;
int main()
{
    while(cin>>a>>b&&a+b!=0)
    {
        if(a%2==0||b%2==0)
            printf("Wonderful!\n");
        else
            printf("What a pity!\n");
    }
    return 0;
}

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=2147

猜你喜欢

转载自blog.csdn.net/YT201758501112/article/details/81261124