N!Again (同余)

N!Again

 WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
Output
For each case, output N! mod 2009
Sample Input

4 
5

Sample Output

24
120

题意:

求N!mod 2009

分析:

这是阶乘啊,是乘起来的数,所以2009!以后每个数的阶乘都含有2009这个因数了,取模一定为0,所以实际需要算的只有2009之前的阶乘

code:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;
typedef long long ll;
const double e = exp(1.0);
const double pi = acos(-1.0);
const ll mod = 2009;
ll fac[3000];
void init(){
    fac[0] = fac[1] = 1;
    for(ll i = 2; i <= 3000; i++){
        fac[i] = (fac[i-1] * i) % mod;
    }
}
int main(){
    ll n;
    init();
    while(scanf("%lld",&n) != EOF){
        if(n >= 2009)
            printf("0\n");
        else
            printf("%lld\n",fac[n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/codeswarrior/article/details/81359882