KiKi's K-Number(hdu 2852)

KiKi's K-Number

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4433    Accepted Submission(s): 2027

Problem Description

For the k-th number, we all should be very familiar with it. Of course,to kiki it is also simple. Now Kiki meets a very similar problem, kiki wants to design a container, the container is to support the three operations.

Push: Push a given element e to container

Pop: Pop element of a given e from container

Query: Given two elements a and k, query the kth larger number which greater than a in container;

Although Kiki is very intelligent, she can not think of how to do it, can you help her to solve this problem?

Input

Input some groups of test data ,each test data the first number is an integer m (1 <= m <100000), means that the number of operation to do. The next m lines, each line will be an integer p at the beginning, p which has three values:
If p is 0, then there will be an integer e (0 <e <100000), means press element e into Container.
If p is 1, then there will be an integer e (0 <e <100000), indicated that delete the element e from the container  
If p is 2, then there will be two integers a and k (0 <a <100000, 0 <k <10000),means the inquiries, the element is greater than a, and the k-th larger number.

Output

For each deletion, if you want to delete the element which does not exist, the output "No Elment!". For each query, output the suitable answers in line .if the number does not exist, the output "Not Find!".

Sample Input

5
0 5
1 2
0 6
2 3 2
2 8 1
7
0 2
0 2
0 4
2 1 1
2 1 2
2 1 3
2 1 4

Sample Output

No Elment!
6
Not Find!
2
2
4
Not Find!

Source

2009 Multi-University Training Contest 4 - Host by HDU

首先,用树状数组维护小于等于e的个数,第1,2步是模板,第三步直接二分查找,注意是大于e的第k个数,所以k要加上小于等于e的个数。

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5+5;
int c[maxn];
int lowbit(int x)
{
    return x&(-x);
}
void update(int x,int v)
{
    while(x<=maxn)
    {
        c[x]+=v;
        x+=lowbit(x);
    }
}
int sum(int x)
{
    int ans=0;
    while(x>0)
    {
        ans+=c[x];
        x-=lowbit(x);
    }
    return ans;
}
int Search(int k)
{
    int ans=maxn,L=1,R=maxn;
    while(L<=R)
    {
        int mid=(L+R)/2;
        if(sum(mid)>=k) ans=mid,R=mid-1;
        else L=mid+1;
    }
    return ans;
}
int main()
{
    int m,p,e,k;
    while(scanf("%d",&m)==1)
    {
        memset(c,0,sizeof(c));
        while(m--)
        {
            scanf("%d%d",&p,&e);
            if(!p) update(e,1);
            else if(p==1)
            {
                if(sum(e)-sum(e-1)==0) printf("No Elment!\n");
                else update(e,-1);
            }
            else
            {
                scanf("%d",&k);
                if(sum(maxn)-sum(e)<k) printf("Not Find!\n");
                else printf("%d\n",Search(sum(e)+k));
            }
        }
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41061455/article/details/81491004