【HDU 1525】Euclid's Game

【题目】

传送门

Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):

25 7
11 7
4 7
4 3
1 3
1 0

an Stan wins.

Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

34 12
15 24
0 0

Sample Output

Stan wins
Ollie wins


【分析】

洛谷传送门,翻译就去洛谷上看吧。

这道题的话,我们分情况来讨论(令 n m n≥m ):

一、若 n % m = 0 n\%m=0 ,即 n n m m 的倍数,明显先手必胜。

二、若 n > 2 m n>2m ,由于两个人绝顶聪明,他们肯定知道 ( n % m , m ) (n\%m,m) 是必胜点还是必败点。

  1. ( n % m , m ) (n\%m,m) 是必胜点,那他肯定就把这个点转换成 ( n % m , m ) (n\%m,m) ,他就必胜。
  2. ( n % m , m ) (n\%m,m) 是必败点,那他就把这个点转换成 ( n % m + m , m ) (n\%m+m,m) ,他的对手就只能转移成 ( n % m , m ) (n\%m,m) 这个必败点,因此他必胜。

那么综上,此时肯定是先手必胜。

三、若 m < n < 2 m m<n<2m ,那这时只可能有一种转换方法,就是换成 ( n m , m ) (n-m,m) ,这样就暴力计算直到符合上面的两种情况就可以了。


【代码】

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
	int n,m,winner;
	while(~scanf("%d%d",&n,&m))
	{
		winner=0;
		if(!n&&!m)  break;
		if(n<m)  swap(n,m);
		while(m)
		{
			if(!(n%m)||n>=2*m)  break;
			n-=m,swap(n,m),winner^=1;
		}
		puts(winner?"Ollie wins":"Stan wins");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/forever_dreams/article/details/87888986