King's Game HDU - 5643

题目链接
In order to remember history, King plans to play losephus problem in the parade gap.He calls n(1≤n≤5000) soldiers, counterclockwise in a circle, in label 1,2,3…n.

The first round, the first person with label 1 counts off, and the man who report number 1 is out.

The second round, the next person of the person who is out in the last round counts off, and the man who report number 2 is out.

The third round, the next person of the person who is out in the last round counts off, and the person who report number 3 is out.

The N - 1 round, the next person of the person who is out in the last round counts off, and the person who report number n−1 is out.

And the last man is survivor. Do you know the label of the survivor?
Input
The first line contains a number T(0<T≤5000), the number of the testcases.

For each test case, there are only one line, containing one integer n, representing the number of players.
Output
Output exactly T lines. For each test case, print the label of the survivor.
Sample Input
2
2
3
Sample Output
2
2

Hint:
For test case #1:the man who report number 1 1 is the man with label 1 1 , so the man with label 2 2 is survivor.

For test case #1:the man who report number 1 1 is the man with label 1 1 , so the man with label 1 is out. Again the the man with label 2 counts 1 1 , the man with label 3 3 counts 2 2 , so the man who report number 2 2 is the man with label 3 3 . At last the man with label 2 2 is survivor.

首先什么是约瑟夫环?
n个人站成一圈, 编号为1-n, 开始报数, 报到q的淘汰, 求最后的赢家;
对于n, 与 q, ans=(ans+q)%i;q表示报数为q的淘汰, i表示本局有多少人(n), ans表示上局获胜的人的下标(下标由0-(n-1)编号);
而此题中q是变化的, 需要稍微变形;

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
    int n;
    int a[105][105];
    while(cin>>n&&n!=EOF)
    {
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++)
        {
            int x,y;
            cin>>x>>y;
            a[x][y]=1;
        }
        int n1=0,n2=0;
        for(int i=0;i<=100;i++)
        {
            for(int j=0;j<=100;j++)
            {
                if(a[i][j]==1)
                {
                    n1++;
                    break;
                }
            }
        }
        for(int i=0;i<=100;i++)
        {
            for(int j=0;j<=100;j++)
            {
                if(a[j][i]==1)
                {
                    n2++;
                    break;
                }
            }
        }
        int s=min(n1,n2);
        cout<<s<<endl;
    }
    return 0;
}
发布了81 篇原创文章 · 获赞 3 · 访问量 2750

猜你喜欢

转载自blog.csdn.net/weixin_44641254/article/details/104739785