HDU-1087最大上升子序列和

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47907    Accepted Submission(s): 22173


Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the maximum according to rules, and one line one case.
 

Sample Input
 
  
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output
 
  
4 10 3

题意:就是最大上升子序列和.......

思路:用一个数组dp[i]储存到i的时候的最大子序列和

坑点:无

AC代码:

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[1100],num[1100];
int main()
{
    int n,i,j,Max;
    while (cin>>n&&n)
        {
            memset(dp,0,sizeof(dp));
            memset(num,0,sizeof(num));
            for (i=1;i<=n;i++)
                cin>>num[i];
            for (i=1;i<=n;i++)
                {
                    dp[i]=num[i];            //数组一开始的值是num[i]
                    for (j=1;j<i;j++)
                        if (num[i]>num[j])
                            dp[i]=max(dp[j]+num[i],dp[i]);        //当前面有比num[i]小的数字,求最大
                }
            Max=-1;
            for (i=1;i<=n;i++)                        //找出最大的子序列和
                Max=max(Max,dp[i]);
            cout<<Max<<endl;
        }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/z1164754004z/article/details/81040594