HDU-1087 Super Jumping! Jumping! Jumping!

Super Jumping! Jumping! Jumping!

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.
这里写图片描述

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

解题思路:

本题是基础DP问题中的最长上升序列问题,DP数组保存以每一个元素为序列最大值的子序列长度。最后循环找出最长的即可。
代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
  int n;
  while(cin>>n&&n)
  {
    int dp[1010]={0},a[1010]={0};
    for(int i=0;i<n;i++)cin>>a[i];
    dp[0]=a[0];//初始化
    for(int i=1;i<n;i++)
    {
      int tem=0;
      for(int j=0;j<i;j++)
      {
        if(a[j]<a[i])//符合上升序列条件
          if(tem<dp[j])tem=dp[j];//更新最优解
      }
      dp[i]=tem+a[i];//最后赋值最优解
    }
    int mi=0;
    for(int i=0;i<n;i++)
    {
      if(dp[i]>mi)mi=dp[i];//找出最长的
    }
    cout<<mi<<endl;
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/A7_RIPPER/article/details/81051191