HDU 1087 Super Jumping! Jumping! Jumping!---基础DP最长上升子序列的相关问题

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 48758    Accepted Submission(s): 22579

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.


The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2

4 1 2 3 4

4 3 3 2 1

0

Sample Output

4

10

3

题解:这道题差不多就是一道模板题,思路做法都和最简单的最长上升子序列问题的求解相似,这是这道题是求最大和而不是最长序列,该题必须保证后一个元素一定大于前一个元素且不一定是连续的。下面我们来看一下代码:

#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
#define ll long long
using namespace std;

int main()
{
    int n;
    ll a[1005];
    ll d[1005];
    ios::sync_with_stdio(false),cin.tie(0),cout.tie(0);//简而言之可以提高cin、cout的效率
    while(cin>>n&&n!=0)
    {
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
            d[i]=a[i];//一定首先将其初始化
        }
        for(int i=1;i<n;i++)
            for(int j=0;j<i;j++)
            if(a[j]<a[i])d[i]=max(d[i],d[j]+a[i]);
        ll ans=0;
        for(int i=0;i<n;i++)
            ans=max(ans,d[i]);
        cout<<ans<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sinat_41233888/article/details/81285937