HDU-1087 Super Jumping! Jumping! Jumping! (最大上升子序列)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chimchim04/article/details/89393540

 Super Jumping! Jumping! Jumping!

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now. 



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. 
Your task is to output the maximum value according to the given chessmen list. 

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. 
A test case starting with 0 terminates the input and this test case is not to be processed. 

Output

For each case, print the maximum according to rules, and one line one case. 

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

题目大意:从起点到终点,路途上的每个点有一个权值,每次走的点的权值必须比刚刚离开的那一点的权值大,求起点到终点的最大权值和,就是求最大上升子序列

思路:dp [ i ] 是以第i个数为子序列的最后一位的最大和

状态转移方程:dp[i]=max(dp[i],a[i]+dp[j])  (j < i)

如果第j个数小于第i个数 以第j个数结尾的子序列再加上第j个数成为一个新子序列,如果它的和大于 dp[i]

,就更新dp[i]的值

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int N=1005;
int a[N],dp[N];
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            dp[i]=a[i];
        }
        int ans=0;
        for(int i=1; i<=n; i++)
        {
            for(int j=1;j<i;j++)
                if(a[i]>a[j])
                dp[i]=max(dp[i],a[i]+dp[j]);
            //printf("%d\n",dp[i]);
            ans=max(ans,dp[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}


 

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/89393540