PAT (Advanced Level) Practice 1006 Sign In and Sign Out (25)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题意:

输入一组学生去机房的签到时间和离开时间,最早到的负责开门,最晚到的负责关门,并且没有人同时签到和离开,输出最早到的和最晚到的。

C++:

 #include<cstdio>
 #include<cstring>
 using namespace std;
 
 struct student{
 	char ID_number[15];
 	int hh;
 	int mm;
 	int ss;
 	
 }time,early,latest; 
 
 bool compare(student a,student b){
 	if(a.hh != b.hh)	return a.hh > b.hh;
 	if(a.mm != b.mm)	return a.mm > b.mm;
 	return a.ss > b.ss;
 }
 
 int main(){
 	int n;
 	scanf("%d",&n);
 	early.hh=24;   early.mm=60;   early.ss=60;
 	latest.hh=0;   latest.mm=0;   latest.ss=0;
	for(int i=0;i<n;i++){
		scanf("%s %d:%d:%d",time.ID_number,&time.hh,&time.mm,&time.ss);	
		if(!compare(time,early))   early = time;
		
		scanf("%d:%d:%d",&time.hh,&time.mm,&time.ss);	
		if(compare(time,latest))   latest = time;
			
	}
	
	printf("%s %s",early.ID_number,latest.ID_number);
	return 0;
}
	

注:

因为题目对于输入形式已经固定,hh:mm:ss, 并且scanf有一种写法就是:

scanf("%d:%d:%d",&time.hh,&time.mm,&time.ss);

保证输入时按照scanf的格式即可,实现对字符串的划分,从而可以对时间进行快速的判断。

我一开始就是在这里,直接定义了两个字符串,一个表示签到时间,一个表示离开时间,对长字符串进行分割处理,转成int型再判断,虽然我觉得是可行的,但是麻烦了。


猜你喜欢

转载自blog.csdn.net/lili_code/article/details/80639321