PAT Advanced 1006 Sign In and Sign Out

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

由于题目的时间限定在一天内(24*60*60秒),这里将所有的时刻转换成从00:00:00开始经过的秒数,并用timetable数组存储当前秒在教室里的学生编号,最后遍历该数组得到结果。
#include <bits/stdc++.h>

using namespace std;
vector<string> stu;
int timetable[24*3600+10];
int convert(string &raw)
{
    int hh=(raw[0]-'0')*10+(raw[1]-'0');
    int mm=(raw[3]-'0')*10+(raw[4]-'0');
    int ss=(raw[6]-'0')*10+(raw[7]-'0');
    return hh*3600+mm*60+ss;
}
int main()
{
    int M;
    cin>>M;
    string tid,tsignin,tsignout;
    memset(timetable,0,sizeof timetable);
    for(int i=0;i<M;i++)
    {
        cin>>tid>>tsignin>>tsignout;
        int sin=convert(tsignin);
        int sout=convert(tsignout);
        stu.push_back(tid);
        int id=stu.size();
        for(int j=sin;j<=sout;j++)
        {
            timetable[j]=id;
        }
    }
    int ans1=-1,ans2=-1;
    for(int i=0;i<=24*3600+10;i++)
    {
        if(ans1==-1&&timetable[i]!=0)
        {
            ans1=timetable[i];
            break;
        }
    }
    for(int i=24*3600+10;i>=0;i--)
    {
        if(ans2==-1&&timetable[i]!=0)
        {
            ans2=timetable[i];
            break;
        }
    }
    cout<<stu[ans1-1]<<' '<<stu[ans2-1]<<endl;
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/zest3k/p/11450473.html