hdu 简单DP 1008 Common Subsequence

Common Subsequence

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 46   Accepted Submission(s) : 24

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

Sample Input

abcfbc abfcab
programming contest 
abcd mnp

Sample Output

4
2
0

Source

Southeastern Europe 2003


//dp[i][j]代表的是第一个字符串从第1位到第i位
//                第二个字符串从第1位到第j位的最长公共子序列
//子序列是可以不连续的,但是子串是连续的
#include <bits/stdc++.h>
using namespace std;
int dp[1005][1005];
int main()
{
    char a[1005],b[1005];
    a[0]=b[0]='0';    //这个地方很重要第0位初始为‘0’,不能写0
    while(scanf("%s%s",a+1,b+1)!=EOF)   //char数组的scanf输入方式
    {
        int ans=-1;
        memset(dp,0,sizeof(dp));
        int L1=strlen(a),L2=strlen(b);
        for(int i=1; i<L1; i++)
        {
            for(int j=1; j<L2; j++)
            {
                if(a[i]==b[j]) dp[i][j]=dp[i-1][j-1]+1;  
                else dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                ans=max(dp[i][j],ans);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/80995633