J - Greatest Common Increasing Subsequence HDU - 1423

This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.

Input

Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.

Output

output print L - the length of the greatest common increasing subsequence of both sequences.

Sample Input

1

5
1 4 2 5 -12
4
-12 1 2 4

Sample Output

2

题目大意:找到两个数组的最长公共子序列可以不连续

思路这就是一个模板题直接套模板就可以:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
   int N;
   scanf("%d",&N);
   while(N--)
   {
     int n;
     scanf("%d",&n);
     int a[1200],b[1200];
     int i,j;
     for(i=0;i<n;i++)
         scanf("%d",&a[i]);
     int m;scanf("%d",&m);
     for(j=0;j<m;j++)
        scanf("%d",&b[j]);
     int dp[600]={0};
     int maxx=-100;
     for(i=0;i<n;i++)
      {maxx=0;
            for(j=0;j<m;j++)
        {
            if(a[i]==b[j])
               dp[j]=maxx+1;
            if(a[i]>b[j])
               maxx=max(dp[j],maxx);
        }
      }
    int ans=-100;
    for(i=0;i<=m;i++)
        ans=max(ans,dp[i]);
    printf("%d\n",ans);
    if(N!=0)
    printf("\n");
   }
   return 0;
}

猜你喜欢

转载自blog.csdn.net/TANG3223/article/details/81435222
今日推荐