饭卡(基础dp)

Description

电子科大本部食堂的饭卡有一种很诡异的设计,即在购买之前判断余额。如果购买一个商品之前,卡上的剩余金额大于或等于5元,就一定可以购买成功(即使购买后卡上余额为负),否则无法购买(即使金额足够)。所以大家都希望尽量使卡上的余额最少。 
某天,食堂中有n种菜出售,每种菜可购买一次。已知每种菜的价格以及卡上的余额,问最少可使卡上的余额为多少。 
 

Input

多组数据。对于每组数据: 
第一行为正整数n,表示菜的数量。n<=1000。 
第二行包括n个正整数,表示每种菜的价格。价格不超过50。 
第三行包括一个正整数m,表示卡上的余额。m<=1000。 

n=0表示数据结束。 
 

Output

对于每组输入,输出一行,包含一个整数,表示卡上可能的最小余额。
 

Sample Input

 
    
1 50 5 10 1 2 3 2 1 1 2 3 2 1 50 0
 

Sample Output

 
    
-45 32

代码如下:

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stack>
#include<queue>
#include<deque>
using namespace std;
typedef long long ll;
#define MAX 0x3f3f3f3f
#define N 1005
bool cmp(int a,int b)
{
    return a<b ;
}
int main()
{
    int n;
    while(cin >> n,n)
    {
        int dp[5111]={0},p[5111]={0};
        for(int i=0;i<=n-1;i++)
             cin>>p[i];
        sort(p,p+n,cmp);//sort(p,p+n);
        int m;
        cin >> m;
        if(m<5)
        {
            cout<<m<<endl;
            continue;
        }
        m-=5;
        for(int i=0;i<n-1;i++)
        {
            for(int j=m;j>=p[i];j--)
            {
                    dp[j]=max(dp[j],dp[j-p[i]]+p[i]);
            }
        }
        cout<<m+5-dp[m]-p[n-1]<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/baiyi_destroyer/article/details/80571734