N - Common Subsequence 【LCS】

最长公共子序列<--深入理解最长公共子序列请戳

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

LCS模板

code:

#include<iostream>
#include<cstring>
using namespace std;
const int maxn=1005;
int dp[1006][1006];
int main(){
	char a[maxn],b[maxn]; 
	while(cin>>a>>b){
		memset(dp,0,sizeof(dp));
		for(int i=0;i<strlen(a);i++){
			for(int j=0;j<strlen(b);j++){
				if(a[i]==b[j]){
					dp[i+1][j+1]=dp[i][j]+1;
				}
				else{
					dp[i+1][j+1]=max(dp[i+1][j],dp[i][j+1]);
				}
			}
		}
		cout<<dp[strlen(a)][strlen(b)]<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41333844/article/details/81539679
今日推荐