hdu1072题解

hdu1072题解

Nightmare

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14457 Accepted Submission(s): 7027

Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius’ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:

  1. We can assume the labyrinth is a 2 array.
  2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
  3. If Ignatius get to the exit when the exploding time turns to 0, he can’t get out of the labyrinth.
  4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can’t use the equipment to reset the bomb.
  5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
  6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius’ start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius’ target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

Sample Input
3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4
1 0 0 0 1 0 0 1
1 4 1 0 1 1 0 1
1 0 0 0 0 3 0 1
1 1 4 1 1 1 1 1

Sample Output
4
-1
13

作为一个新手,对于queue还一知半解,就没有贸然用bfs来做。这题的dfs关键在于剪枝,避免超时。
以下是代码

#include<iostream>
#include<iomanip>
#include<string>
#include<algorithm>
#define N 0x3f3f3f3f
using namespace std;
int a[10];
int ste[10][10];
int tim[10][10];
int map[10][10];
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};//运用dir数组
int sx , sy , ex, ey;
int m, n;
int Min;
void dfs(int x , int y , int step, int len)
{
	if(len<=0||step>Min) return;
    if(map[x][y]==3)
    {
        if(step<Min)
            Min=step;
        return;
    }
    if(map[x][y]==4)
    len=6;
    if(step>=ste[x][y]&&len<=tim[x][y]) return;//关键的剪枝,判断这个点有没有被走过,再次走到这里时,与上一次进行比较,比较这次的效率与上一次的效率比有没有跟高。
    ste[x][y]=step;
    tim[x][y]=len;
    int i, tx, ty;
    for(i=0;i<4;i++)
    {
        tx=x+dir[i][0];
        ty=y+dir[i][1]; 
		if((tx>=0&&tx<n)&&(ty>=0&&ty<m))
		{
			if(map[tx][ty]!=0)
        	dfs(tx,ty,step+1,len-1);
    	}
    }
    return;
}
int main()
{
    int T ;
    cin>>T;
    while(T--)
    {
        cin>>n>>m;
        int i ,j;
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                cin>>map[i][j];
                if(map[i][j]==2)
                {
                    sx=i;sy=j;
                }
                if(map[i][j]==3)
                {
                    ex=i;ey=j;
                } 
				ste[i][j]=N;
            tim[i][j]=0;
            }
           
        }
        Min=N;
        dfs(sx,sy,0,6);
        if(Min==N)
        cout<<-1;
        else
        cout<<Min;
        cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43458555/article/details/85394206