hdu-1072-Nightmare(bfs+记忆化)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1072

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

 

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

 

Sample Input

3

3 3

2 1 1

1 1 0

1 1 3

4 8

2 1 1 0 1 1 1 0

1 0 4 1 1 0 4 1

1 0 0 0 0 0 0 1

1 1 1 4 1 1 1 3

5 8

1 2 1 1 1 1 1 4

1 0 0 0 1 0 0 1

1 4 1 0 1 1 0 1

1 0 0 0 0 3 0 1

1 1 4 1 1 1 1 1

 

Sample Output

4

-1

13

题目大意:给出一个迷宫,0代表墙(不能走)1代表路,2代表起点,3代表终点,4代表维修点;

一个人带着炸弹从起点开始走,炸弹6分钟爆炸,如果到维修点可以将炸弹的时间调整到6分钟,

这个人如果正好在终点处炸弹爆炸了,会死,

在维修点炸弹爆炸了,还是会死,

走不出迷宫,会死,

问一个人能否走出迷宫,

能走出迷宫:输出走出的最短时间

不能:输出-1;

将地图的可用时间记录,如果能够刷新时间,那么记录,否则忽略(有更优的选择了就不选择这个了)

ac:

#include<stdio.h>
#include<string.h>  
#include<math.h>  
  
//#include<map>   
//#include<set>
#include<deque>  
#include<queue>  
#include<stack>  
#include<bitset> 
#include<string>  
#include<iostream>  
#include<algorithm>  
using namespace std;  

#define ll long long  
#define INF 0x3f3f3f3f  
#define mod 998244353
//#define max(a,b) (a)>(b)?(a):(b)
//#define min(a,b) (a)<(b)?(a):(b) 
#define clean(a,b) memset(a,b,sizeof(a))// 水印 
//std::ios::sync_with_stdio(false);

struct node{
	int x,y,min,time;
	node(int _x=0,int _y=0,int _min=0,int _time=0):x(_x),y(_y),min(_min),time(_time){}
};

int dp[15][15];
int map[15][15];
int fx[4]={1,-1,0,0},fy[4]={0,0,1,-1};
int n,m,strx,stry,edx,edy;

bool judge(int x,int y,int less)
{
	if(x>=0&&y>=0&&x<n&&y<m)
	{
		if(map[x][y]&&less)
			return 1;
	}
	return 0;
}

int bfs()
{
	queue<node> que;
	while(que.size())
		que.pop();
	que.push(node(strx,stry,6,0));
	dp[strx][stry]=6;
	while(que.size())
	{
		node now=que.front();
		que.pop();
		if(now.x==edx&&now.y==edy&&now.min>0)
			return now.time;
		for(int i=0;i<4;++i)
		{
			node can;
			can.x=now.x+fx[i];
			can.y=now.y+fy[i];
			can.min=now.min-1;
			can.time=now.time+1;
			if(judge(can.x,can.y,can.min))
			{
				if(map[can.x][can.y]==4)
					can.min=6;
				if(dp[can.x][can.y]<can.min)
				{
					dp[can.x][can.y]=can.min;
					que.push(can);
				}
			}
		}
	}
	return -1;
}

int main()
{
	std::ios::sync_with_stdio(false);
	int t;
	cin>>t;
	while(t--)
	{
		clean(map,0);
		clean(dp,0);
		cin>>n>>m;
		for(int i=0;i<n;++i)
		{
			for(int j=0;j<m;++j)
			{
				cin>>map[i][j];
				if(map[i][j]==2)
					strx=i,stry=j;
				if(map[i][j]==3)
					edx=i,edy=j;
			}
		}
		cout<<bfs()<<endl;
	}
}

猜你喜欢

转载自blog.csdn.net/qq_40482358/article/details/81637704