HDU1072 Nightmare(dfs、bfs、记忆化搜索)

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes. 

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1. 

Here are some rules: 
1. We can assume the labyrinth is a 2 array. 
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too. 
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth. 
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb. 
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish. 
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6. 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth. 
There are five integers which indicate the different type of area in the labyrinth: 
0: The area is a wall, Ignatius should not walk on it. 
1: The area contains nothing, Ignatius can walk on it. 
2: Ignatius' start position, Ignatius starts his escape from this position. 
3: The exit of the labyrinth, Ignatius' target position. 
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas. 

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1. 

Sample Input

3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4 
1 0 0 0 1 0 0 1 
1 4 1 0 1 1 0 1 
1 0 0 0 0 3 0 1 
1 1 4 1 1 1 1 1 

Sample Output

4
-1
13

这个人做了个噩梦,身处迷宫,并且迷宫里有炸弹,要在炸弹爆炸(炸弹定时6分钟)之前走出这个迷宫,一分钟走一步,

看他是被炸死,还是活着走出迷宫,

如果能出去,就输出他必须用来找到迷宫出口的最短时间,

不能就输出 -1 

DFS+剪枝

/*
0 是墙不能走,1可以走,2开始的位置,3出口,4,炸弹装置
*/
#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#include <cstdio>
#include <queue>
#include <stack>
using namespace std;
#define inf 0x3f3f3f3f
int mapp[10][10],n,m,sx,sy,ex,ey,minn,tim[10][10],step[10][10];
int dx[4]={0,1,0,-1};//tim 表示走到 i,j用时多少,step代表 走到i,j步数是多少
int dy[4]={1,0,-1,0};//len时间  cnt步数
void dfs(int x,int y,int len,int cnt)
{
    if(x<0||y<0||x>=n||y>=m)return ;
    if(len<=0||cnt>=minn) return ;
    if(mapp[x][y]==0) return ;
    if(mapp[x][y]==3)
    {
        if(cnt<minn) minn=cnt;
        return ;
    }
    if(mapp[x][y]==4)
    {
        len=6;
    }
    /*从当前点x,y走到下一个可能点的距离大于从其他途径到tx,ty的距离,
且到tx,ty点时的剩余时间大于由x,y点到tx,ty点后的剩余时间,就跳过.
(从其他路径到tx,ty有更短的距离和更短的时间那这个点接下去就不用遍历了,因为最优解不可能出现在这条路径上,所以提前剪掉)*/
    if(cnt>=step[x][y]&&tim[x][y]>=len) return ;
    step[x][y]=cnt;
    tim[x][y]=len;
    for(int i=0;i<4;i++)
    {
        int tx=x+dx[i];
        int ty=y+dy[i];
        dfs(tx,ty,len-1,cnt+1);
    }
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        memset(tim,0,sizeof(tim));
        memset(step,inf,sizeof(step));
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                cin>>mapp[i][j];
                if(mapp[i][j]==2)
                {
                    sx=i;
                    sy=j;
                }
                else if(mapp[i][j]==3)
                {
                    ex=i;
                    ey=j;
                }
            }
        }
        int len=6;
        int cnt=0;
        minn=inf;
        dfs(sx,sy,len,cnt);
        if(minn==inf )
            cout<<"-1"<<endl;
        else cout<<minn<<endl;
    }return 0;
}

BFS 

#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#include <cstdio>
#include <queue>
#include <stack>
using namespace std;
#define inf 0x3f3f3f3f
int mapp[10][10],n,m;
int dir[4][2]={{0,1},{0,-1},{-1,0},{1,0}};
struct node
{
    int x,y;
    int step,time;//记录步数和时间
}s;
void bfs()
{
    queue<node > q;//队列实现
    node q1,q2;//交换值,相当于temp;
    q.push(s);
    //队列为空时 说明 已经扫描到结果或者完全扫描结束(还没找到结果)
    while(!q.empty())
    {
        q1=q.front();//将队头的数据拿出来
        q.pop();//将队头弹出
        //开始上下左右搜
        for(int i=0;i<4;i++)
        {
            q2.x=q1.x+dir[i][0];
            q2.y=q1.y+dir[i][1];
            q2.step=q1.step+1;
            q2.time=q1.time-1;
            if(q2.x>=0&&q2.y>=0&&q2.x<n&&q2.y<m&&mapp[q2.x][q2.y]!=0&&q2.time>0)
            {
                if(mapp[q2.x][q2.y]==3)
                {
                    cout<<q2.step<<endl;//找到结束
                    return ;
                }
                else if(mapp[q2.x][q2.y]==4)
                {
                    q2.time=6;
                    mapp[q2.x][q2.y]=0;//标记已经走过
                } q.push(q2);
            }

        }

    }cout<<"-1"<<endl;
    return ;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                cin>>mapp[i][j];
                if(mapp[i][j]==2)
                {
                    s.x=i;
                    s.y=j;
                    s.time=6;
                    s.step=0;
                }
            }
        }
        bfs();
    }return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40046426/article/details/81665912