hdu 1072Nightmare(bfs 状态设计)

Nightmare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14340    Accepted Submission(s): 6974


 

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

 

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

 

Sample Input

 

3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1

 

Sample Output

 

4 -1 13

 

Author

Ignatius.L

 

增加一个属性表示炸弹剩余时间,注意判断ntime>1

Recommend

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#define maxn 100
using namespace std;
int dx[4]={1,0,-1,0};
int dy[4]={0,1,0,-1};
int sx,sy,ex,ey;
int n,m;
int mp[maxn][maxn];
int dis[maxn][maxn][100];
struct node
{
    int x,y,time,dis;
    node()
    {

    }
    node(int x,int y,int time,int dis):x(x),y(y),time(time),dis(dis)
    {}



};
int bfs()
{ queue<node>q;
memset(dis,-1,sizeof(dis));
while(!q.empty())
    q.pop();
    node u=node(sx,sy,6,0);
dis[sx][sy][6]=0;
q.push(u);

while(!q.empty())
{node v,w;
v=q.front();
q.pop();
    for(int i=0;i<4;i++)
    {int nx=v.x+dx[i];
    int ny=v.y+dy[i];
    int ndis=v.dis+1;
    int ntime=v.time-1;
    if(nx>=1&&nx<=n&&ny>=1&&ny<=m&&mp[nx][ny]!=0)
    {
        if(mp[nx][ny]==4)
            ntime=6;

            if(dis[nx][ny][ntime]==-1||dis[nx][ny][ntime]>ndis)
               {
                   dis[nx][ny][ntime]=ndis;
                   if(ntime>1)
                    q.push(node(nx,ny,ntime,ndis));
          if(nx==ex&&ny==ey)
            return ndis;

    }

}
    }

}
return -1;
}
int main()
{int t;
scanf("%d",&t);
while(t--)
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        {scanf("%d",&mp[i][j]);
        if(mp[i][j]==2)
        {
            sx=i;
            sy=j;
        }
        else if(mp[i][j]==3)
        {ex=i;
        ey=j;

        }

}
int ans=bfs();
if(ans==-1)
    printf("-1\n");
else printf("%d\n",ans);

}
return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/84350542