Nightmare ---HDU1072

Nightmare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6419    Accepted Submission(s): 3124


Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input
33 32 1 11 1 01 1 34 82 1 1 0 1 1 1 01 0 4 1 1 0 4 11 0 0 0 0 0 0 11 1 1 4 1 1 1 35 81 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output
4-113
 

题意:在n×m的地图上,0表示墙,1表示空地,2表示人,3表示目的地,4表示有定时炸弹重启器。定时炸弹的时间是6,人走一步所需要的时间是1。每次可以上、下、左、右移动一格。当人走到4时如果炸弹的时间不是0,可以重新设定炸弹的时间为6。如果人走到3而炸弹的时间不为0时,成功走出。求人从2走到3的最短时间。每个结点都是可以重复访问,但炸弹重置点不要重复走,因为,走到炸弹重置点时时间就会被设置为最大时间,当重新返回时时间又设成最大,但此时已走的步数肯定增加了,所以如果存在较优解的话那么肯定在第一次到这点后就可以找到较优解.

#include <iostream>
#include <bits/stdc++.h>

using namespace std;
struct node
{
    int x,y,time,step;
} pos;
int n,m,fg;
int s[10][10];
queue<node>q;

void bfs()
{
    node ps,nq;
    int tx,ty;
    int nt[5][3]= {{1,0},{-1,0},{0,1},{0,-1}};
    while(!q.empty())
    {
        nq=q.front();
        q.pop();
        for(int i=0; i<4; i++)
        {
            tx=nq.x+nt[i][0];
            ty=nq.y+nt[i][1];
            if(tx>=0&&ty>=0&&tx<n&&ty<m&&s[tx][ty]!=0&&nq.time>1)   //注意判断
            {
                if(s[tx][ty]==3)
                {
                    fg=1;
                    cout<<nq.step+1<<endl;
                    return;
                }
                else
                {
                    if(s[tx][ty]==4)  //注意炸弹的时候的处理
                    {
                        s[tx][ty]=0;
                        ps.time=6;
                    }
                    else
                        ps.time=nq.time-1;
                    ps.x=tx;
                    ps.y=ty;
                    ps.step=nq.step+1;
                    q.push(ps);
                }
            }
        }
    }
    return;
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        fg=0;
        queue<node>q1;
        swap(q,q1);
        cin>>n>>m;
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
               scanf("%d",&s[i][j]);
                if(s[i][j]==2)
                {
                    pos.x=i;
                    pos.y=j;
                    pos.time=6;
                    pos.step=0;
                    q.push(pos);
                }
            }
        }
       bfs();
        if(!fg)
            cout<<"-1"<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/stanmae/article/details/80294769