hdu1072走出迷宫(bfs)

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius’ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:

  1. We can assume the labyrinth is a 2 array.
  2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
  3. If Ignatius get to the exit when the exploding time turns to 0, he can’t get out of the labyrinth.
  4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can’t use the equipment to reset the bomb.
  5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
  6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
    There are five integers which indicate the different type of area in the labyrinth:
    0: The area is a wall, Ignatius should not walk on it.
    1: The area contains nothing, Ignatius can walk on it.
    2: Ignatius’ start position, Ignatius starts his escape from this position.
    3: The exit of the labyrinth, Ignatius’ target position.
    4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
    Output
    For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
    Sample Input
    3
    3 3
    2 1 1
    1 1 0
    1 1 3
    4 8
    2 1 1 0 1 1 1 0
    1 0 4 1 1 0 4 1
    1 0 0 0 0 0 0 1
    1 1 1 4 1 1 1 3
    5 8
    1 2 1 1 1 1 1 4
    1 0 0 0 1 0 0 1
    1 4 1 0 1 1 0 1
    1 0 0 0 0 3 0 1
    1 1 4 1 1 1 1 1
    Sample Output
    4
    -1
    13

跟红蓝大战那道题差不多,就是死法不用,不过有几个细节,注意:到延时站时,爆炸时间刚好为0无法延时,到出口时炸弹刚好为0也会死。因为还涉及到炸弹且有延时,所以并不是第一个到达某点是最好的,所以标记应该是同个地点剩同个时间(拒爆炸)只需走一次

ac代码

#include<iostream>       
#include<cstdlib>      
#include<cstdio> 
#include<cstring>      
#include<cmath>           
#include<string>      
#include<cstdlib>      
#include<iomanip>      
#include<vector>      
#include<list>      
#include<map>      
#include<queue>    
#include<algorithm>
using namespace std;
int p[10][10][10], v[10][10],kkk,x,y,aa,bb;
int s1[4] = { 0,0,1,-1 }, s2[4] = { 1,-1,0,0 };
struct node
{
	int t,r1,r2,sum;
};//t为该位置炸弹距爆炸时间(r1,r2),sum为走到该位置的步数
void bfs()
{
	int p1, p2, p3;
	queue<node>q;
	node a, next;
	p[x][y][6] = 1;
	a.t = 6; a.r1 = x; a.r2 = y; a.sum = 0;
	q.push(a);
	while (!q.empty())
	{
		a = q.front();
		q.pop();
		if (a.t > 0)//时间大于零才能继续走
		{
		if (v[a.r1][a.r2] == 3)//这个的前提也是到出口时间要大于0
		{
			kkk = 0;	cout << a.sum << endl; return;
		}
			for (int i = 0; i < 4; i++)
			{
				p1 = next.r1 = a.r1 + s1[i];
				p2 = next.r2 = a.r2 + s2[i];
				if (v[p1][p2] != 0&&v[p1][p2]!=2&&p1>0&&p2>0&&p1<=aa&&p2<=bb)//下一步要在边界还不能碰到岩石,因为刚开始的时间为6分钟,后面走到出口时间会小于6分钟,且步数多了,所以出口只需走一次。
				{
					
						p3 = next.t = a.t - 1;
					if (v[p1][p2] == 4&&p3>0)//上下不能颠倒,走到下一步时,时间已经耗了一分钟了,走完还剩时间(距爆炸)才能延时(变为6分钟)
						p3 = next.t = 6;
					if (!p[p1][p2][p3])
					{
						p[p1][p2][p3] = 1;
						next.sum = a.sum + 1;
						q.push(next);
						
					}
				}
			}
		}
	}
}
int main()
{
	int n;
	cin >> n;
	while (n--)
	{
		memset(p, 0, sizeof(p));
		kkk = 1;
		
		cin >> aa >> bb;
		for (int i = 1; i <= aa; i++)
		{
			for (int j = 1; j <= bb; j++)
			{
				cin >> v[i][j];
				if (v[i][j] == 2) { x = i; y = j; }//找到出口位置
			}
		}
		bfs();
		if (kkk)cout << -1 << endl;


	}

}

猜你喜欢

转载自blog.csdn.net/weixin_43965698/article/details/87400228