HDU1072 Nightmare

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

Sample Input

 

3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1

Sample Output

 

4 -1 13

PS:看题目就知道是一道搜索题,但是不一样的是这里可以重复走,只有数值为4的点只能 走一次,在标志的时候这里要注意下。

AC代码:

#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<map>
#include<queue>
#include<set>
#include<cmath>
#include<stack>
#include<string>
const int maxn=5e3+10;
const int mod=1e9+7;
const int inf=1e8;
#define me(a,b) memset(a,b,sizeof(a))
typedef long long ll;
using namespace std;
int fx[4][2]={0,1,0,-1,1,0,-1,0},maps[20][20],n,m;
bool vis[20][20];
struct node
{
    int x,y,t,step;
};
bool check(int x,int y)
{
    if(x<0||x>=n||y<0||y>=m||vis[x][y]||maps[x][y]==0)
        return 0;
    return 1;
}
int bfs(int x,int y)
{
    queue<node>q;
    node now,next;
    now.x=x;now.y=y;now.t=6;now.step=0;
    vis[now.x][now.y]=1;
    q.push(now);
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        if(maps[now.x][now.y]==3&&now.t>0)
            return now.step;
        for(int i=0;i<4;i++)
        {
            int x1=now.x+fx[i][0];
            int y1=now.y+fx[i][1];
            if(check(x1,y1))
            {
                if(maps[x1][y1]==4&&now.t-1>0)
                {
                    next.x=x1,next.y=y1,next.t=6,next.step=now.step+1;
                    vis[x1][y1]=1;
                    q.push(next);
                }
                else if(now.t-1>0)
                {
                    next.x=x1,next.y=y1,next.t=now.t-1,next.step=now.step+1;
                    q.push(next);
                }
            }
        }
    }
    return -1;
}
int main()
{
    int t;cin>>t;
    while(t--)
    {
        int x,y;cin>>n>>m;
        me(vis,0),me(maps,0);
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
            {
                cin>>maps[i][j];
                if(maps[i][j]==2)
                    x=i,y=j;
            }
        cout<<bfs(x,y)<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41292370/article/details/81901147