HDU 1072Nightmare

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

Sample Input

3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1

Sample Output

4 -1 13

使用BFS,可以避免使用DFS遍历造成的超时(或者DFS进行有效的剪枝)。

注意与其他迷宫不同,人物可以走回头路,但是注意走回头路的可能会进入无限循环:因此由题意知”4“可以延长时间,避免陷入循环那么”4“只能走一次(避免进入无限循环),其他地方可以多次走!

#include<iostream>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
int t, n, m, time = 6;
int map[10][10], vis[10][10], vis4[10][10];   //vis记录最短步数,vis4标记位置”4"
int sx, sy, ex, ey, dx[4] = { 0,1,0,-1 }, dy[4] = { 1,0,-1,0 };
struct node
{
	int x;
	int y;
	int time;
}tmp1,tmp2;
int main()
{
	cin >> t;
	while (t--)
	{
		cin >> n >> m;
		queue<node> q;
		memset(vis, 0, sizeof(vis));
		memset(vis4, 0, sizeof(vis4));
		for (int j = 1; j <= n; j++)
					{
						for (int k = 1; k <= m; k++)
						{
							cin >> map[j][k];
							if (map[j][k] == 2)
								sx = j, sy = k;
							if (map[j][k] == 3)
								ex = j, ey = k;
						}
					}
		tmp1.x = sx, tmp1.y = sy,tmp1.time=6,vis[sx][sy] = 0;
		q.push(tmp1);
		while (!q.empty())
		{
			tmp1 = q.front(); q.pop();
			if (tmp1.x == ex&&tmp1.y == ey)     //到达终点则跳出循环
			{
				cout << vis[tmp1.x][tmp1.y] << endl;
				break;
			}
			if (tmp1.time > 1)                  //时间允许继续走,则四个方向试着走
			{
				for (int i = 0; i < 4; i++)
				{
					tmp2.x = tmp1.x + dx[i], tmp2.y = tmp1.y + dy[i], tmp2.time = tmp1.time - 1;
					if (tmp2.x >= 1 && tmp2.x <= n&&tmp2.y >= 1 && tmp2.y <= m&& map[tmp2.x][tmp2.y] != 0&&vis4[tmp2.x][tmp2.y]==0)
					{
						vis[tmp2.x][tmp2.y] = vis[tmp1.x][tmp1.y] + 1;
						if (map[tmp2.x][tmp2.y] == 4)
						{
							tmp2.time = 6;
							vis4[tmp2.x][tmp2.y] = 1;  //“4”该位置走过一次,标记
						}
						q.push(tmp2);
					}
				}
			}
		}
		if (vis[ex][ey] == 0)
			cout << "-1" << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/slience_646898/article/details/82712787