Nightmare HDU - 1072(BFS)

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius’ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:

  1. We can assume the labyrinth is a 2 array.
  2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
  3. If Ignatius get to the exit when the exploding time turns to 0, he can’t get out of the labyrinth.
  4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can’t use the equipment to reset the bomb.
  5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
  6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
    There are five integers which indicate the different type of area in the labyrinth:
    0: The area is a wall, Ignatius should not walk on it.
    1: The area contains nothing, Ignatius can walk on it.
    2: Ignatius’ start position, Ignatius starts his escape from this position.
    3: The exit of the labyrinth, Ignatius’ target position.
    4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
    Output
    For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
    Sample Input
    3
    3 3
    2 1 1
    1 1 0
    1 1 3
    4 8
    2 1 1 0 1 1 1 0
    1 0 4 1 1 0 4 1
    1 0 0 0 0 0 0 1
    1 1 1 4 1 1 1 3
    5 8
    1 2 1 1 1 1 1 4
    1 0 0 0 1 0 0 1
    1 4 1 0 1 1 0 1
    1 0 0 0 0 3 0 1
    1 1 4 1 1 1 1 1
    Sample Output
    4
    -1
    13
    思路:困扰了挺久的一道题目。这道题目不一样的是,点是可以重复走的。因此就不能标记路径那样了。我们设vis[i][j][t]代表着(i,j)这个点在t时刻已经走到过了。这样再加一个标记t,如果在t时刻(i,j)这个点已经走过了,就不用重复走了。然后在4的时候注意判断一下就可以了。
    代码如下:
#include<bits/stdc++.h>
#define ll long long
#define Pll pair<int,int>
#define inf 0x3f3f3f3f
using namespace std;

const int maxx=10;
int a[maxx][maxx];
int d[][2]={{1,0},{0,1},{-1,0},{0,-1}};
int vis[maxx][maxx][7];
int n,m,sx,sy,ex,ey;

struct node{
	int x,y,cnt,num;
	node(int a,int b,int c,int d)
	{
		x=a,y=b,cnt=c;num=d;
	}
};
inline int bfs()
{
	queue<node> q;
	q.push(node(sx,sy,6,0));
	a[sx][sy]=0;
	while(q.size())
	{
		node u=q.front();
		q.pop();
		if(u.x==ex&&u.y==ey) return u.num;
		for(int i=0;i<4;i++)
		{
			int tx=u.x+d[i][0];
			int ty=u.y+d[i][1];
			if(tx<1||tx>n||ty<1||ty>m||a[tx][ty]==0) continue;
			if(a[u.x][u.y]!=4&&u.cnt-1>0&&vis[tx][ty][u.cnt-1]==0) 
			{
				q.push(node(tx,ty,u.cnt-1,u.num+1));
				vis[tx][ty][u.cnt-1]=1;
			}
			else if(a[u.x][u.y]==4&&vis[tx][ty][5]==0)
			{
				q.push(node(tx,ty,5,u.num+1));
				vis[tx][ty][5]=1;
			}
		}
	}
	return -1;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		memset(vis,0,sizeof(vis));
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++) for(int j=1;j<=m;j++) scanf("%d",&a[i][j]);
		for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++)
		{
			if(a[i][j]==2) sx=i,sy=j;
			if(a[i][j]==3) ex=i,ey=j;
		}
		cout<<bfs()<<endl;
	}
	return 0;
}

努力加油a啊,(o)/~

发布了652 篇原创文章 · 获赞 101 · 访问量 5万+

猜你喜欢

转载自blog.csdn.net/starlet_kiss/article/details/105309903