1041 Be Unique (20分)【散列】

1041 Be Unique (20分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

 解题思路:

由于所有数字的大小满足number<=10^4^,因此我们可以利用一个int数组来存放每个数字出现的次数,例如cnt[i]表示第i个数字的出现次数。

#include<iostream>
using namespace std;

int a[100001];
int cnt[10001] = { 0 };

int main()
{
	int n;
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		cin >> a[i];
		cnt[a[i]]++;
	}
	int ans = -1;
	for (int i = 0; i < n; i++)
	{
		if (cnt[a[i]] == 1)
		{
			ans = a[i];
			break;
		}
	}
	if (ans == -1)
		cout << "None" << endl;
	else cout << ans << endl;
	return 0;
}
发布了119 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/lovecyr/article/details/104758845