1041 Be Unique (20分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​^4]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10
​5
​​ ) and then followed by N bets. The numbers are separated by a space.

Output Specification:
For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

题⽬⼤意:

给n个数字,按照读⼊顺序,哪个数字是第⼀个在所有数字中只出现⼀次的数字。如果所有
数字出现都超过了⼀次,则输出None

分析:

建⽴⼀个数组,存储每个数字出现的次数,然后遍历⼀遍输⼊的顺序看是否有出现次数为1的数

//1041 Be Unique (20分)
#include <iostream>
#include <vector>
using namespace std;
int vis[100000];
vector<int> k;
int main() 
{
	int N;
	cin>>N;
	for(int i=1;i<=N;i++)
	{
		int num;
		cin>>num;
		k.push_back(num);
		vis[num]++;
	}
	int i;
	for(i=0;i<k.size();i++)
	{
		if(vis[k[i]]==1)
		{
			cout<<k[i]<<endl;
			break;
		}		
	}
	if(i==k.size())
		cout<<"None"<<endl;
	return 0;
}
发布了4 篇原创文章 · 获赞 0 · 访问量 140

猜你喜欢

转载自blog.csdn.net/DayDream_x/article/details/104324740