PAT A1041 Be Unique (20分)

题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805444361437184

题目描述
Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10^​4​​ ]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

输入
Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10^​5​​ ) and then followed by N bets. The numbers are separated by a space.

输出
For each test case, print the winning number in a line. If there is no winner, print None instead.

样例输入
7 5 31 5 88 67 88 17

样例输出
31

代码

#include <cstdio>

int main() {
	int n, a[100010], hash[100010] = {0};
	bool flag = false;
	scanf("%d", &n);
	for(int i = 0; i < n; i ++) {
		scanf("%d", &a[i]);
		hash[a[i]]++;
	}
	for(int i = 0; i < n; i++) {
		if(hash[a[i]] == 1) {
			printf("%d\n", a[i]);
			flag = true;
			break;
		}
	}
	if(flag == false)
		printf("None\n");
	return 0;
}
发布了288 篇原创文章 · 获赞 12 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/Rhao999/article/details/104668974