PAT1041. Be Unique (20)

1041. Be Unique (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None





basic题目,采用哈希

#include<iostream>
#include<algorithm>
#include<string>
#include<queue>
#include<cstring>

using namespace std;

int mp[100005];
int que[100005];

int main()
{
    ios::sync_with_stdio(false);
    int n;
    cin>>n;
    memset(mp, 0, sizeof(mp));
    for(int i=0;i<n;++i)
    {
        int m;
        cin>>m;
        mp[m]++;
        que[i] = m;
    }
    bool flag = false;
    for(int i=0;i<n;++i)
    {
        if(mp[que[i]] == 1)
        {
            flag = true;
            cout<<que[i]<<endl;
            break;
        }
    }
    if(!flag)
        cout<<"None"<<endl;
    return 0;
}



猜你喜欢

转载自blog.csdn.net/acsuccess/article/details/78755611