PAT Advanced 1041 Be Unique (20分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17
 

Sample Output 1:

31
 

Sample Input 2:

5 888 666 666 888 888
 

Sample Output 2:

None

这题理解题意后是简单题,主要考察了哈希映射。

找出数字只出现一次的数。

#include <iostream>
using namespace std;
int m[10000] = {0};
int main(){
    int N;
    cin >> N;
    int arr[N];
    for(int i = 0; i < N; i++){
        cin >> arr[i];
        m[arr[i]]++;
    }
    for(int i = 0; i < N; i++){
        if(m[arr[i]] == 1){
            cout << arr[i];
            return 0;
        }
    }
    cout << "None";
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/littlepage/p/12236079.html