1041 Be Unique(20 分)

1041 Be Unique(20 分)
Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10
​4
​​ ]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:
Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10
​5
​​ ) and then followed by N bets. The numbers are separated by a space.

Output Specification:
For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None

解题思路:
用类似打表的方法,统计每个数出现的次数。按输出顺序遍历,当有次数为1的数时,输出,没有就输出None。

#include<cstdio>
const int maxn=1e5+10;
int book[maxn]={0} ;
int a[maxn];
int main(){
    int n,x;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d",&x);
        a[i]=x;
        book[x]++;
    }
    int ans=-1;
    for(int i=0;i<n;i++){
        if(book[a[i]]==1){
            ans=a[i];
            break;
        }
    }
    if(ans==-1) printf("None\n");
    else printf("%d\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chenyutingdaima/article/details/82050184