1041 Be Unique (20 分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

结尾无空行

Sample Output 1:

31

结尾无空行

Sample Input 2:

5 888 666 666 888 888

结尾无空行

Sample Output 2:

None

结尾无空行

#include<iostream>
using namespace std;
int main()
{
   	int a[100005],map1[100005]={0};
    int N;
    cin>>N;
    for(int i=0;i<N;i++){
        cin>>a[i];
        int value=a[i];
        map1[value]++; 
    }
    for(int i=0;i<N;i++)
    {
    	int value=a[i];
    	if(map1[value]==1)
    	{
    		cout<<a[i];
    		return 0;
		}
	}
	cout<<"None";
}

猜你喜欢

转载自blog.csdn.net/qq_52245648/article/details/119722963