1041 Be Unique (20 分)

1041 Be Unique (20 分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None
#include<bits/stdc++.h>
using namespace std;
const int maxn=1e6+10;
vector<vector<int> >q;
int a[maxn];
int main()
{
    q.clear();
    q.resize(100011);
    int n;
    cin>>n;
    for(int i=1; i<=n; i++)
    {
        int x;
        cin>>x;
        a[i]=x;
        q[x].push_back(x);
    }
    int flas=0;
    for(int i=1; i<=n; i++)
    {
        int x=a[i];
        if(q[x].size()==1)
        {
            flas=1;
            cout<<q[x][0]<<endl;
            break;
        }
    }
    if(flas==0)
        printf("None\n");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chen_zan_yu_/article/details/84929899